Ik gebruik de Automatische Updater niet

Gebruikersavatar

Auteur van discussie
Schopenhauer
Site Admin
Berichten: 122
Lid geworden op: do aug 09, 2018 11:53 am

Ik gebruik de Automatische Updater niet

#1

Bericht door Schopenhauer » vr dec 28, 2018 7:34 pm

Om dit PHP forum te upgraden naar de nieuwste versie van phpBB, gebruik ik de automatische updater NIET meer.
Al in versie 3.1 x kreeg je bij gebruik van het upgradepakket te maken met het installeren van extra te downloaden bestanden.
Om die extra bestanden te installeren, diende je secuur te werk gaan, anders loop je de kans dat er problemen ontstaan en het forum ontoegankelijk wordt.
Wat thans ook wel gebeurt, is dat er een vervelende timeout kan ontstaan bij het upgraden.....

Daarom ben ik bij een upgrade overgestapt op het downloaden van het complete installatiepakket.
Echter, gebruik dat pakket niet zomaar - want dat zou betekenen dat het bestaande forum vernietigd wordt voor een nieuw op te starten forum.

Met het volledige installatiepakket dien je eerst voorbereidend werk te gaan verrichten - zowel op de server als met het door jouw uitgepakte installatiepakket.

Vooraleer jij aan de slag gaat jouw forum te gaan upgraden, dien je ingelogd te zijn en in het Beheerderspaneel via Foruminstellingen prosilver als standaard te gebruiken thema te hebben ingesteld.

Het uitgepakte installatie bestand voorbereiden:

Klik de mappen open totdat je bij alle forumbestanden aankomt.
Verwijder nu uit deze mappen en bestanden de volgende onderdelen:

  • het bestand config.php
  • de map files/
  • de map images/
  • de map store/



Op de server inloggen en daar het volgende doen:

verwijder daar alle bestanden, behalve die hieronder vermeld staan:

  • het bestand config.php
  • de map ext/
  • de map files/
  • de map images/
  • de map store/


Zijn de voorbereiding gereed gekomen - dan wordt het zaak de upgrade bestanden naar jou server te uploaden.

Is dat gebeurd, dan pal achter jouw forumlink /install typen.
In mijn geval is dat spaceship-aarde.nl/install.

Als alles goed gaat wordt de database geupdated (duurt niet lang) en daarna kan je inloggen in de ACP = Beheerderspaneel.

Op de server verwijder je de map install - anders geeft het forum een foutmelding.

Indien om onbegrijpelijke redenen het Beheerspaneel aangeeft dat de forumversie na de upgrade verouderd is, herhaal dan bovenstaande, maar dan met het installatiepakket wat je hier weghaalt: https://www.phpbb.com/downloads/

Download het pakket en pak het uit.

Kopieer nu uit het vorige installatie pakket uit de map language de map nl en plak deze map vervolgens in het nieuwe installatiebestand in de map language erbij.

Herhaal nu de voorbereidingen in het nieuwe installatiebestand en op de server.

Is alles weer conform de hierboven beschreven handelingen afgehandeld, dan wederom de installatie opstarten.
Is alles op rolletjes gegaan, zal daarna de ACP aangeven dat jouw forum de nieuwste phpBB versie bevat.


Alle oorlog-propaganda, alle geschreeuw en leugens en haat,
komen altijd van mensen die niet vechten (George Orwell).

Terug naar “Problemen in phpBB forum software”